Applies To
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- FlexPLM 12.0 to 12.1
- Windchill PDMLink 12.0 to 12.1
- Windchill ProjectLink 12.0 to 12.1
- Windchill PDM Essentials 12.0 to 12.1
- PTC Arbortext Content Manager 10 to 12.1
Description
A common practice while administering Windchill is to clear the servers cache. This article walks through how to clear the Windchill server cache only. For clearing Windchill Users Client's cache and other optional cache/temporary files that can also be deleted see the references section.
Cause
-
What are the signs and behaviors that clearing of cache is required?
- If advised by Technical Support or in a reference document
- Might be required after update or upgrade of Windchill
- Might be required after modifying Info*Engine configurations
- Required when Java Server Pages (JSP) are modified ,for instance: customized to achieve business requirements
- Cache need to cleared for the search tab not occurring issue
- Classification tree in the Manage classifications can not be displayed
- Classification tree shows internal names instead of display names in Nonconformance
- Global search tab doesn't appear in Product and Library contexts
- Windchill Performance is running slow
- User is unable to create new components Start part and cannot open existing parts
- Upgrade manager fails on phase "update container template"
- Users which are part of PTC Author License and PTC View and Print Only License Groups are unable to access Classification Explorer
- Users are unable to log in to Windchill after updating the license file
Resolution
- Log into the Windchill server with a user that has administrative rights.
- Stop all Windchill Related Services.
- Click Start and Search for Services.
- Click Services.
- Stop all Windchill related services
- Example:
- Windchill Server
- Windchill HTTP Server
- Windchill Directory Server
- Windchill Solr Server
- Example:
- Navigate to Windchill Home.
- Windchill Home is the location on the server where Windchill runs.
- Example: D:\PTC\Windchill_12\Windchill
- Windchill Home is the location on the server where Windchill runs.
- Delete the Apache Tomcat cache/temporary Files
- In Windchill home navigate to the tomcat folder and delete the instances folder inside of the tomcat folder
- Example: D:\PTC\Windchill_12\Windchill\tomcat\instances
- Delete the bold folder
- Example: D:\PTC\Windchill_12\Windchill\tomcat\instances
- In Windchill home navigate to the tomcat folder and delete the instances folder inside of the tomcat folder
- Delete the Info*Engine cache/temporary Files
- In Windchill Home navigate to \tasks\codebase\com\infoengine and delete the compiledTasks folder
- Example: D:\PTC\Windchill_12\Windchill\tasks\codebase\com\infoengine\compiledTasks
- Delete the bold folder
- Example: D:\PTC\Windchill_12\Windchill\tasks\codebase\com\infoengine\compiledTasks
- In Windchill Home navigate to \tasks\codebase\com\infoengine and delete the compiledTasks folder
- Delete the Workflow Expression cache
- In Windchill home, navigate to \codebase\wt\workflow and delete the expr folder
- Example: D:\PTC\Windchill_12\Windchill\codebase\wt\workflow\expr
- Delete the bold folder
- Example: D:\PTC\Windchill_12\Windchill\codebase\wt\workflow\expr
- In Windchill home, navigate to \codebase\wt\workflow and delete the expr folder
- Start Windchill services stopped in step 1 starting the Windchill Server LAST.
Reference
- https://www.ptc.com/en/support/article/cs29555
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